provider connection
 

Compatible Browsers for Provider Connection

The features and services on Provider Connection are designed to work in specific browsers.

Recommended Browsers for Windows Operating Systems

For the best overall experience, we recommend Internet Explorer 8.0 or Firefox 4.0 or later versions, which we have tested extensively for our website.

Please note that we can not guarantee that features will display or function properly in browsers that are not compatible with our website.

Currently, our website is not compatible with Safari browsers.

If you are not using a supported browser, please download a compatible version of Microsoft Internet Explorer or Firefox to ensure you can access all the tools and features on Provider Connection. This applies to Internet Explorer versions prior to 8.0, and Firefox versions prior to 4.0.

Download the most recent version of Internet Explorer or Firefox now.

Still Having Trouble Using Provider Connection?

If you are already using Internet Explorer 8.0 or later and still experiencing issues with our site, you may need to change your Compatibility View settings in the Internet Explorer browser.

First, go to the Tools menu in the browser and ensure that Compatibility View is not checked. If it is checked, click on it to remove the setting.

Next, go to the Tools menu and select Compatibility View Settings. At the bottom of the Compatibility View Settings box, ensure that all check-boxes are un-checked. Then click Close.